Δεν μου τρέχει το ερώτημα

Συζητήσεις για την βάση δεδομένων MySQL και το phpMyAdmin

Συντονιστές: WebDev Moderators, Super-Moderators

Απάντηση
quit
Δημοσιεύσεις: 147
Εγγραφή: 09 Δεκ 2008 11:54

Δεν μου τρέχει το ερώτημα

Δημοσίευση από quit » 29 Ιουν 2011 19:32

καλησπερα παιδια, θέλω να σας ρωτησω που μπορεί να οφείλεται ότι δεν μου επιστρεφει τιποτα το ερώτημα σε ένα select ενώ οταν το τρέχω στο phpmyadmin δουλεύει κανονικα?τι φταίει??

Άβαταρ μέλους
dimsis
Reporter
Δημοσιεύσεις: 7994
Εγγραφή: 25 Ιούλ 2001 03:00

Δεν μου τρέχει το ερώτημα

Δημοσίευση από dimsis » 29 Ιουν 2011 19:39

Αν είναι δυναμικό (που λογικά θα είναι) τότε πιθανών να δίνεις τιμή σε κάποια μεταβλητή που σου κόβει τις εγγραφές (οι οποίες εννοείται πως έχεις ελέγξει και υπάρχουν κανονικα στην ανεβασμένη βάση, στον σωστό πίνακα).

Το connection με την βάση γίνετε κανονικά και άλλα ερωτήματα γυρνάνε δεδομένα;

quit
Δημοσιεύσεις: 147
Εγγραφή: 09 Δεκ 2008 11:54

Δεν μου τρέχει το ερώτημα

Δημοσίευση από quit » 29 Ιουν 2011 19:46

dimsis σοθ παραθετω το select με το query

<select class="input2" name="cat" style="font-size:11px">
<?php
$result = mysql_query("SELECT * FROM categories,categories_translation WHERE categories.cat_id = categories_translation.cat_id AND categories.parent='0'");
while($row = mysql_fetch_array($result)){?>
<option style="padding-top:10px;" value="<?php echo $row['cat_id'] ?>"><?php echo $row['cat_name ']; ?></option>
<?php }?>
</select>

quit
Δημοσιεύσεις: 147
Εγγραφή: 09 Δεκ 2008 11:54

Δεν μου τρέχει το ερώτημα

Δημοσίευση από quit » 29 Ιουν 2011 20:46

τοθέμα ειναι ότι παραπάνω το ακριβώς ίδιο ερώτημα μου επιστρέφει κανονικά τα αποτελέσματα

Άβαταρ μέλους
mrpc
WebDev Moderator
Δημοσιεύσεις: 3393
Εγγραφή: 03 Μάιος 2000 03:00
Τοποθεσία: Εξάρχεια
Επικοινωνία:

Δεν μου τρέχει το ερώτημα

Δημοσίευση από mrpc » 29 Ιουν 2011 20:54

Μήπως έχεις κλείσει τη σύνδεση με τη βάση;

quit
Δημοσιεύσεις: 147
Εγγραφή: 09 Δεκ 2008 11:54

Δεν μου τρέχει το ερώτημα

Δημοσίευση από quit » 30 Ιουν 2011 00:05

λοιπον πριν λιγο εγραψα
echo "<option style=padding-top:10px; value='".$row['cat_id']."'>".$row['cat_name']."</option>";
και το δεχτηκε κανονικα. Τι να πω??

Άβαταρ μέλους
panxer
Δημοσιεύσεις: 113
Εγγραφή: 26 Ιουν 2011 20:29
Τοποθεσία: Athens, Greece
Επικοινωνία:

Δεν μου τρέχει το ερώτημα

Δημοσίευση από panxer » 10 Ιούλ 2011 16:42

quit έγραψε:dimsis σοθ παραθετω το select με το query

<select class="input2" name="cat" style="font-size:11px">
<?php
$result = mysql_query("SELECT * FROM categories,categories_translation WHERE categories.cat_id = categories_translation.cat_id AND categories.parent='0'");
while($row = mysql_fetch_array($result)){?>
<option style="padding-top:10px;" value="<?php echo $row['cat_id'] ?>"><?php echo $row['cat_name ']; ?></option>
<?php }?>
</select>
<?php echo $row['cat_id'] ; ?>

Απάντηση

Επιστροφή στο “MySQL”

Μέλη σε σύνδεση

Μέλη σε αυτήν τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης